We can confirm that a manual reinstall of the app is fixing the issue. Just uninstall and install Quick Filters from the Marketplace. No data is lost when reinstalling within a few days.
We're still waiting for Atlassian to continue their investigation. There are only three affected customers left, which we have also contacted via email.
Since a workaround was found, all affected customers were contacted and Atlassian doesn't consider this to be an incident, we're closing our incident as well.
Posted Apr 10, 2024 - 11:45 UTC
Update
Atlassian is not considering it as an incident, since only a few customers are affected and they cannot reproduce it. They'll continue investigating during business hours.
We are now updating our app descriptor to force a reinstall of the app for all customers, which hopefully fixes the issue for the few affected customers.
Posted Apr 09, 2024 - 10:41 UTC
Update
Atlassian has responded to the incident and is still trying to reproduce the issue.
Posted Apr 08, 2024 - 16:01 UTC
Investigating
Quick Filters is currently unable to call Jira APIs for a few customers. The app is not working for these customers, and we're currently escalating an incident with Atlassian.
Posted Apr 08, 2024 - 14:01 UTC
This incident affected: Quick Filters for Jira Dashboards.