External Data Extension Fields are Facing Render Problems on 'Create Screen'

Incident Report for codefortynine

Postmortem

Summary

On August 7, the External Data for Jira Fields – Extension experienced rendering issues on the Global Create Issue Screen. A platform change by Atlassian caused fields with dependencies to misbehave, affecting customer work item creation. After investigation and reproduction work, we escalated to Atlassian with a minimal test case. They deployed a fix on August 8. During the incident, we shipped improvements to reduce customer impact.

Impact

Affected Components: Extension fields of type Search Field and Info Panel with dependencies on the Global Create Work Item Screen

Symptoms:

  • Search Fields sometimes lost selected values after selection
  • Info Panels repeatedly reloaded
  • Required fields blocked work item creation when affected

Data integrity: No data loss; issues limited to UI interaction

Timeline (UTC)

  • 08‑07 08:07 - First support ticket reported flashing Info Panel
  • 08‑07 09:41 - Internal triage and investigation began
  • 08‑07 14:30 - Incident declared internally
  • 08‑07 14:58 - Created public incident on status page
  • 08‑07 15:39 - Escalated to Atlassian with video and code example
  • 08‑07 18:58 - Atlassian acknowledged and began active investigation
  • 08‑07 22:25 - Atlassian posted public incident: https://jira-work-management.status.atlassian.com/incidents/82mmpdj46q9l
  • 08‑08 10:15 - Deployed improvement for affected fields
  • 08‑08 11:35 - Atlassian deployed fix; behavior returned to normal
  • 08‑08 14:12 - Verified fix internally and with customers; closed incident

Root cause analysis

Initial investigation was challenging as the platform change wasn't immediately apparent. Eventually, we identified that an Atlassian platform change in the create work item experience caused dependent custom fields (Search Field, Info Panel) to re‑evaluate unexpectedly. Atlassian did not provide detailed technical specifics of the change.

Resolution and recovery

  • Immediate Action: Deployed client‑side improvement to stabilize affected fields
  • Platform Fix: Atlassian reverted/adjusted their change, restoring original behavior
  • Verification: Confirmed through manual testing and customer feedback

Learnings & Improvements

  • Enhanced field resilience to reduce impact from similar platform changes
  • Reviewed and refined incident response process
Posted Aug 18, 2025 - 08:58 UTC

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 14:12 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 08, 2025 - 12:46 UTC

Monitoring

The fix is available on all our test instances. It is currently being deployed across all regions by Atlassian. We will keep monitoring the situation.
Posted Aug 08, 2025 - 11:55 UTC

Update

Atlassian responded with: Please note that the fix is currently being deployed across all regions. Some users can already start noticing improvements. The next update will be provided as soon as the issue is fully resolved.
Posted Aug 08, 2025 - 09:34 UTC

Identified

Atlassian has acknowledged the issue and is actively tracking its status here:
https://jira-work-management.status.atlassian.com/incidents/82mmpdj46q9l
Posted Aug 08, 2025 - 07:56 UTC

Update

Atlassian is now actively investigating on there end as well.
Posted Aug 07, 2025 - 19:18 UTC

Update

We're currently escalating an incident with Atlassian and waiting for their response.
Posted Aug 07, 2025 - 16:11 UTC

Update

We are continuing to investigate this issue.
Posted Aug 07, 2025 - 15:05 UTC

Investigating

We are currently investigating this issue.
Posted Aug 07, 2025 - 14:58 UTC
This incident affected: External Data for Jira Fields - Extension.