We have just rolled back our own temporary fixes and warning messages. Create and confirm is available again and everything should work as expected now.
Posted Dec 22, 2023 - 06:01 UTC
Update
We have updated Deep Clone to no longer automatically run when using an issue menu action. This should prevent everyone from accidentally cloning issues twice. We have also documented the workaround within Deep Clone for "Create and confirm" to use Bulk Clone instead.
Posted Dec 21, 2023 - 13:41 UTC
Update
Using "Create and confirm" with Single Clone is also affected, since the "Create issue" screen is opened behind the Deep Clone dialog.
We have raised the incident with Atlassian, waiting for confirmation and a status page entry on their side.
Posted Dec 21, 2023 - 10:23 UTC
Investigating
In our apps Deep Clone for Jira and Merge Agent for Jira, when clicking on the issue menu and selecting "Deep Clone"/"Merge", the dialog being opened is shown twice.
This leads to any actions being triggered by opening the dialog to be triggered twice, e.g. when using a Deep Clone Preset with the "Add as an action to issue menu" and "Clone immediately" options set.
This seems to be an issue with Jira itself. We're currently notifying Atlassian and raising an incident with them. We're investigating if we can mitigate the duplicate cloning behavior when using the Preset in an action menu.
Posted Dec 21, 2023 - 10:08 UTC
This incident affected: Deep Clone for Jira App and Merge Agent for Jira.