Post Function clones failing with the error 'no valid active user exists'

Incident Report for codefortynine

Resolved

The issue has been resolved. Post Function clones that are targeting a different Jira instance will now be successful again, even if the user triggering the clone does not exist on the target instance.
Posted Nov 29, 2023 - 19:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2023 - 17:01 UTC

Investigating

We have observed that some Post Function clone jobs are failing with the following Error:

`Add-on 'com.codefortynine.deep-clone-for-jira' disallowed to impersonate the user because 'no valid active user exists'`

This error happened under the following conditions:
- The type of clone is "Post Function"
- The Post Function clone is cloning to a different instance
- The user triggering the Post Function does not exist on the target instance, or does not have sufficient permissions
Posted Nov 29, 2023 - 16:10 UTC
This incident affected: Deep Clone for Jira App.