Deep Clone for Jira outage
Incident Report for codefortynine
Postmortem

A stack overflow error during an HTTP request caused the HTTP connection manager to shut down, preventing any further HTTP request to be served. This is the default behavior of the implementation we are using.

We first restarted our server to make it up and running again. Unfortunately, since the issue happened at midnight in our time zone, the server was down for roughly nine hours.

We then fixed the cause of the stack overflow error, which was due to a very uncommon and unexpected edge case not covered by our implementation.

We also made sure that if a stack overflow error ever happened again, it would not shut down the HTTP connection manager, thus having no impact on other requests.

Posted Jan 05, 2021 - 15:50 UTC

Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 08:30 UTC
Monitoring
There has been a Deep Clone for Jira outage from 04.01.2021 23:00 UTC to 05.01.2021 08:30 UTC. During this time, Deep Clone for Jira could not be used.

The issue is resolved and we are monitoring it. The incident had no repercussions other than the outage.
Posted Jan 04, 2021 - 23:00 UTC
This incident affected: Deep Clone for Jira App.