Atlassian confirmed that the incident has been identified, and their engineering team is actively working to resolve the issue.
Posted Apr 29, 2026 - 16:00 UTC
Update
We are continuing to investigate this issue.
Posted Apr 29, 2026 - 12:45 UTC
Investigating
We are currently experiencing delayed Jira Events that impact multiple apps to process changes slower than usual. We are seeing delays from up to 30 minutes, mainly in the EU region. The affected apps are:
- Comment Custom Fields for Jira - Comment History Logs for Jira - Version Sync for Jira - Dynamic Custom Fields for Jira - Snipe-IT for Jira - Merge Agent for Jira
We are working closely with Atlassian to get this delayed processing resolved.
Posted Apr 29, 2026 - 12:44 UTC
This incident affects: Comment Custom Fields for Jira, Comment History Log for Jira, Dynamic Custom Fields for Jira, Merge Agent for Jira, Snipe-IT for Jira, and Version Sync for Jira.